[CCNA图文笔记]-33-经典综合实验

引言

这篇文章是这一系列笔记的综合篇,文章以一个综合实验将CCNA笔记中介绍的大部分知识串联起来;文中会涉及到设备的远程管理、VLAN的划分、VTP协议的使用、STP协议的配置、动态和静态路由协议的使用、DHCP和NAT的配置、PPP和ACL的应用等。

文章目录

0×1.综合实验拓扑图

实验环境是"Cisco Packet Tracer 6.2",搭建下面的拓扑图,图中路由器型号是2811,在路由控制面板中给所有路由添加两块WIC-2T串行接口模块(放到四个格子的下面两个格子中);

Cisco-CCNA- final-1

在添加模块的时候注意先将电源关闭,添加完成后再开启;两台交换机型号是2960;图中有两台服务器,其中Server2模拟Internet中的一台服务器,Server1模拟内网中的一台服务器。

Cisco-CCNA- final-2

根据这个拓扑,完成下面的实验要求。

0×2.实验要求

1)在Cisco Packet Tracer 6.2中搭建上面的拓扑图,注意设备间线缆类型的选择;

2)给每台设备配置IP地址;

R1配置:
fa0/0 打开
fa0/0.1 192.168.1.1/24
fa0/0.2 192.168.2.1/24
fa0/0.3 192.168.3.1/24
s0/0/0 12.1.1.1/24

R2配置:
s0/0/0 12.1.1.2/24 DCE端需要配置时钟
s0/0/1 23.1.1.2/24 DCE端
s0/1/1 24.1.1.2/24 DCE端

R3配置:
s0/0/1 23.1.1.3/24
s0/0/0 34.1.1.3/24 DCE端

R4配置:
s0/1/1 24.1.1.4/24
s0/0/0 34.1.1.4/24
fa0/0 174.1.1.1/24

Server1配置:
IP地址 192.168.2.2
子网掩码 255.255.255.0
默认网关 192.168.2.1

Server2配置:
IP地址 174.1.1.2
子网掩码 255.255.255.0
默认网关 174.1.1.1

SW1配置:
VLAN1 192.168.1.2/24
默认网关 192.168.1.1

SW2配置:
VLAN1 192.168.1.3/24
默认网关 192.168.1.1

PC1、PC2、PC3使用DHCP自动获取IP,Server1和PC1属于VLAN2,VLAN2所在子网是192.168.2.0/24。PC2和PC3属于VLAN3,VLAN3所在子网是192.168.3.0/24。

3)配置4台路由以及2台交换机,使他们都能支持远程Telnet登录;配置他们的特权密码和Console端口密码,所有的密码统一配置成"ccna",要求密码不能在配置文件中明文显示(使用加密)。

4)配置VTP协议,让SW1成为VTP Server,SW2为VTP Client,VTP配置中域名配置成"ccna",密码同样是"ccna"。

5)在SW1上面配置VLAN2和VLAN3,让SW2可以通过VTP协议学习到SW1上的VLAN信息。配置两台交换机上面链接的4台终端设备到各自的VLAN中,配置SW1与R1相连的接口为主干。

6)配置STP协议,使SW1成为VLAN1、VLAN2和VLAN3的根交换机。

7)在R1上配置DHCP协议,使得PC1、PC2、PC3都能准确获取IP地址、网关,DNS服务器的地址是174.1.1.2。

8)配置R1使用默认路由指向R2,配置R2、R3、R4运行OSPF协议,配置完成后4台路由器能够互访。

9)R1和R2之间配置PPP封装,使用CHAP验证密码是"ccna"。

10)在R1上配置NAT,使得内网Server1、PC1、PC2、PC3能够通过PAT共享R1的s0/0/0接口IP地址访问Internet(R2、R3、R4和Server2模拟的是Internet);同时在R1上配置静态PAT,让Internet上的用户可以通过R1的s0/0/0接口的80端口访问内网Server1的WWW服务。

11)在R1上配置ACL,拒绝VLAN3的主机访问Server2的WWW服务,其他服务不受影响。

0×3.实验配置

这一部分按照上面的要求开始配置。

1)首先按照拓扑图给各设备连上线;

2)配置IP地址;

R1配置:

					/*主接口只要打开即可*/
					R1(config)#int fa 0/0
					R1(config-if)#no shut

					/*这是VLAN1的网关*/
					R1(config-if)#int fa 0/0.1
					R1(config-subif)#encapsulation dot1Q 1
					R1(config-subif)#ip add 192.168.1.1 255.255.255.0
					R1(config-subif)#no shut

					/*这是VLAN2的网关*/
					R1(config-subif)#int fa 0/0.2
					R1(config-subif)#encapsulation dot1Q 2
					R1(config-subif)#ip add 192.168.2.1 255.255.255.0
					R1(config-subif)#no shut

					/*这是VLAN3的网关*/
					R1(config-subif)#int fa 0/0.3
					R1(config-subif)#encapsulation dot1Q 3
					R1(config-subif)#ip add 192.168.3.1 255.255.255.0
					R1(config-subif)#no shut

					/*和R2相连的接口,因为是DTE端所以不需要配置时钟*/
					R1(config-subif)#int s 0/0/0
					R1(config-if)#ip add 12.1.1.1 255.255.255.0
					R1(config-if)#no shut
					R1(config-if)#end
					

R2配置:

					R2(config)#int s 0/0/0
					R2(config-if)#ip add 12.1.1.2 255.255.255.0
					R2(config-if)#clock rate 64000
					R2(config-if)#no shut
					R2(config-if)#int s 0/0/1
					R2(config-if)#ip add 23.1.1.2 255.255.255.0
					R2(config-if)#clock rate 64000
					R2(config-if)#no shut
					R2(config-if)#int s 0/1/1
					R2(config-if)#ip add 24.1.1.2 255.255.255.0
					R2(config-if)#clock rate 64000
					R2(config-if)#no shut
					R2(config-if)#end
					

R3配置:

					R3(config)#int s 0/0/1
					R3(config-if)#ip add 23.1.1.3 255.255.255.0
					R3(config-if)#no shut
					R3(config-if)#int s 0/0/0
					R3(config-if)#ip add 34.1.1.3 255.255.255.0
					R3(config-if)#clock rate 64000
					R3(config-if)#no shut
					R3(config-if)#end
					

R4配置:

					R4(config)#int s 0/0/0
					R4(config-if)#ip add 34.1.1.4 255.255.255.0
					R4(config-if)#no shut
					R4(config-if)#int s 0/1/1
					R4(config-if)#ip add 24.1.1.4 255.255.255.0
					R4(config-if)#no shut
					R4(config-if)#int fa 0/0
					R4(config-if)#ip add 174.1.1.1 255.255.255.0
					R4(config-if)#no shut
					R4(config-if)#end
					

SW1配置:

					/*给SW1配置一个网关,并配置一个可网管的IP地址*/
					SW1(config)#ip default-gateway 192.168.1.1
					SW1(config)#int vlan 1
					SW1(config-if)#ip add 192.168.1.2 255.255.255.0
					SW1(config-if)#no shut
					SW1(config-if)#end
					

SW2配置:

					SW2(config)#ip default-gateway 192.168.1.1
					SW2(config)#int vlan 1
					SW2(config-if)#ip add 192.168.1.3 255.255.255.0
					SW2(config-if)#no shut
					SW2(config-if)#end
					

Server1配置,需要关闭Server1的DHCP服务,否则PC1可能会从Server1去获取IP地址(思科模拟器不支持DHCP snooping,如果是在GNS3+IOU环境搭建此实验的朋友可以尝试着配置DHCP snooping可信端口与DHCP发送速率)首先在Server1的配置面板中配置IP:

Cisco-CCNA- final-3

Server1关闭DHCP:

Cisco-CCNA- final-4

Server2配置:

Cisco-CCNA- final-5

将三台PC设备的IP配置调整成DHCP自动获取,因为还没有在R1上配置DHCP,所以暂时他们还获取不到IP地址。

Cisco-CCNA- final-6

3)配置设备远程登录以及管理密码;

R1配置:

					/*配置特权密码*/
					R1(config)#enable secret ccna

					/*配置Console端口密码*/
					R1(config)#line co 0
					R1(config-line)#pass ccna
					R1(config-line)#login

					/*配置R1允许远程Telnet管理*/
					R1(config-line)#line vty 0 4
					R1(config-line)#pass ccna
					R1(config-line)#login
					R1(config-line)#exit

					/*给所有保存在配置文件中的明文密码加密,在没有设置这条命令前,可以在特权配置模式下输入"R1# show running-config"查看一下,vty和console密码都是明文显示的,配置后就变成加密显示了*/
					R1(config)#service password-encryption
					R1(config)#end
					

R2配置:

					R2(config)#enable secret ccna
					R2(config)#line co 0
					R2(config-line)#pass ccna
					R2(config-line)#login
					R2(config-line)#line vty 0 4
					R2(config-line)#pass ccna
					R2(config-line)#login
					R2(config-line)#exit
					R2(config)#service password-encryption
					R2(config)#end
					

R3、R4、SW1、SW2配置和R1、R2相同,这里就不贴出来了,请参考上面的配置自己配置好这些设备。

4)配置VTP协议;

SW1配置:

					/*配置和SW2相连的端口为主干端口*/
					SW1(config)#int fa 0/23
					SW1(config-if)#swi mod trunk

					/*在真实交换机中还应该配置主干封装协议,思科模拟器没有模拟出下面这条命令,但实际环境中一定要配置*/
					SW1(config-if)#swi trunk enc dot1q
					/*允许所有vlan*/
					SW1(config-if)#swi trunk allow vlan all

					/*配置与R1相连的端口为主干*/
					SW1(config-if)#int fa 0/22
					SW1(config-if)#swi mod trunk
					SW1(config-if)#swi trunk enc dot1q
					SW1(config-if)#swi trunk allow vlan all

					SW1(config-if)#int fa 0/24
					SW1(config-if)#swi mod trunk
					SW1(config-if)#swi trunk enc dot1q
					SW1(config-if)#exit

					/*配置VTP*/
					SW1(config)#vtp domain ccna
					SW1(config)#vtp pass ccna
					SW1(config)#vtp mode server
					SW1(config)#end
					

SW2配置:

					SW2(config)#int fa 0/23
					SW2(config-if)#swi mod trunk
					SW2(config-if)#swi trunk enc dot1q
					SW2(config-if)#int fa 0/24
					SW2(config-if)#swi mod trunk
					SW2(config-if)#swi trunk enc dot1q
					SW2(config-if)#exit

					SW2(config)#vtp domain ccna
					SW2(config)#vtp pass ccna
					/*SW2配置成VTP Client*/
					SW2(config)#vtp mode client
					SW2(config)#end
					

5)配置VLAN并将接口加入对应的vlan;

SW1配置:

					SW1(config)#vlan 2
					SW1(config-vlan)#name vlan2
					SW1(config-vlan)#vlan 3
					SW1(config-vlan)#name vlan3
					SW1(config-vlan)#exit
					SW1(config)#int fa 0/1
					SW1(config-if)#swi mod acc
					SW1(config-if)#swi acc vlan 2
					SW1(config-if)#int fa 0/2
					SW1(config-if)#swi mod acc
					SW1(config-if)#swi acc vlan 3
					SW1(config-if)#end
					

SW2配置:

					/*确保从VTP server上学到了VLAN后,将对应接口加入这些VLAN中*/
					SW2(config)#int fa 0/1
					SW2(config-if)#swi mod acc
					SW2(config-if)#swi acc vlan 2
					SW2(config-if)#int fa 0/2
					SW2(config-if)#swi mod acc
					SW2(config-if)#swi acc vlan 3
					SW2(config-if)#end
					

6)配置STP;

SW1配置:

					/*将SW1配置成VLAN1/2/3的根交换机*/
					SW1(config)#spanning-tree vlan 1,2,3 root primary
					SW1(config)#end
					

7)在R1上配置DHCP;

R1配置:

					R1(config)#ip dhcp excluded-address 192.168.2.1
					R1(config)#ip dhcp excluded-address 192.168.3.1
					R1(config)#ip dhcp pool pool-1
					R1(dhcp-config)#network 192.168.2.0 255.255.255.0
					R1(dhcp-config)#default-router 192.168.2.1
					R1(dhcp-config)#dns-server 174.1.1.2
					R1(dhcp-config)#exit
					R1(config)#ip dhcp pool pool-2
					R1(dhcp-config)#default-router 192.168.3.1
					R1(dhcp-config)#network 192.168.3.0 255.255.255.0
					R1(dhcp-config)#dns-server 174.1.1.2
					R1(dhcp-config)#end
					

确保配置完成DHCP服务后,PC1、PC2、PC3都可以获得正确的IP地址。

8)配置静态路由和动态路由协议;

R1配置:

					/*指向R2的默认路由*/
					R1(config)#ip route 0.0.0.0 0.0.0.0 12.1.1.2
					R1(config)#end
					

R2配置:

					/*所有接口都宣告进OSPF进程*/
					R2(config)#router ospf 1
					R2(config-router)#net 0.0.0.0 255.255.255.255 area 0
					R2(config-router)#end
					

R3配置:

					R3(config)#router ospf 2
					R3(config-router)#net 0.0.0.0 255.255.255.255 area 0
					R3(config-router)#end
					

R4配置:

					R4(config)#router ospf 3
					R4(config-router)#net 0.0.0.0 255.255.255.255 area 0
					R4(config-router)#end
					

9)配置PPP;

R1配置:

					/*配置CHAP验证时需要使用的用户名和密码*/
					R1(config)#username R2 pass ccna

					/*配置PPP封装和CHAP验证*/
					R1(config)#int s 0/0/0
					R1(config-if)#encapsulation ppp
					R1(config-if)#ppp authentication chap
					R1(config-if)#end
					

R2配置:

					R2(config)#username R1 password ccna
					R2(config)#int s 0/0/0
					R2(config-if)#encapsulation ppp
					R2(config-if)#ppp authentication chap
					R2(config-if)#end
					

10)配置NAT;

R1配置:

					/*指定对内端口和对外端口*/
					R1(config)#int fa 0/0.1
					R1(config-subif)#ip nat inside
					R1(config-subif)#int fa 0/0.2
					R1(config-subif)#ip nat inside
					R1(config-subif)#int fa 0/0.3
					R1(config-subif)#ip nat inside
					R1(config-subif)#int s0/0/0
					R1(config-if)#ip nat outside
					R1(config-if)#exit

					/*配置允许内部那些地址进行NAT转换*/
					R1(config)#access-list 1 permit 192.168.1.0 0.0.0.255
					R1(config)#access-list 1 permit 192.168.2.0 0.0.0.255
					R1(config)#access-list 1 permit 192.168.3.0 0.0.0.255

					/*开启转换*/
					R1(config)#ip nat inside source list 1 interface s 0/0/0 overload

					/*
					 * 使用静态端口映射,
					 * 让外网可以通过R1的s0/0/0接口IP访问内网Server1的WWW服务。
					 */
					R1(config)#ip nat inside source static tcp 192.168.2.2 80 12.1.1.1 80
					R1(config)#end
					

开启静态映射后,打开Server2的"Desktop"控制面板,使用WEB浏览器输入12.1.1.1就能直接打开Server1的WWW服务默认页面。

Cisco-CCNA- final-7

11)配置ACL阻止VLAN3中的计算机访问Server2的WWW服务。

在没有配置ACL之前,PC2、PC3能够正常通过WEB浏览器访问174.1.1.2的WWW服务(大家可以在"Desktop"面板中用Web browser测试访问一下)。

R1配置:

					/*使用扩展ACL,仅阻止VLAN3去往Server2 TCP 80端口的流量。*/
					R1(config)#access-list 100 deny tcp 192.168.3.0 0.0.0.255 host 174.1.1.2 eq 80
					R1(config)#access-list 100 permit ip any any

					/*在子接口上应用这个扩展ACL*/
					R1(config)#int fa 0/0.3
					R1(config-subif)#ip access-group 100 in
					R1(config-subif)#end

					/*这个ACL配置完成后PC2、PC3再使用WEB去浏览174.1.1.2就连接不上了,但除80端口外,其他服务不受影响。*/
					

实验完成。

为了方便大家学习,我将这个实验的完整配置和拓扑保存了下来,大家可以去网盘[超经典综合实验-密码都是ccna]下载这个实验的配置,用"Cisco Packet Tracer"打开即可。